介绍

本文档涉及了以下内容:

  • 与安装相关的注记

  • 功能更新

  • 和内核相关的更新

  • 驱动更新

  • 技术预览

  • 已解决的问题

  • 已知问题

红帽企业 Linux 4 .7 的某些更新可能没有出现在这个版本的发行注记中。更新的红帽企业 Linux 4 .7 发行注记可以在下面的网址找到:

http://www.redhat.com/docs/manuals/enterprise/

与安装相关的注记

以下部分包括了与 Anaconda 安装程序以及安装红帽企业 Linux 相关的信息。

备注

当从红帽企业 Linux 4 的次要版本(比如从 4.5 到 4.6)更新到红帽企业 Linux 4.7 时,建议您使用红帽网络完成更新,建议您通过托管的网页用户界面或者红帽网络 Satelite 使用红帽网络进行更新。

如果您要在没有可用网络连接的情况下升级系统,请使用 Anaconda 的 "Upgrade" 功能。但请注意:Anaconda 处理诸如附加程序库相依性或者第三方应用程序的能力有限。另外,Anaconda 会在日志文件中记录安装错误信息,而不是以交互方式显示出错信息。

因此,红帽建议您在离线升级系统时应该测试并确定升级配置文件的完整性。请在升级您的产品环境前仔细查看日志中是否有出错信息。

不支持在原地进行红帽企业 Linux 主要版本间的升级(例如:从红帽企业 Linux 3 升级到红帽企业 Linux 4.7)。虽然 Anaconda 的 "Upgrade" 选项允许您执行此操作,但并不保证升级后的操作系统可正常工作。在原地进行的跨主要版本的升级无法保留所有系统设置、服务和自定义的配置。因此,红帽强烈建议您在进行主要版本间的升级时执行全新安装。

  • 如果您需要复制红帽企业 Linux 4.7 光盘的内容(例如为了筹备网络安装),请只复制操作系统光盘的内容。不要复制附加光盘或任何层次产品光盘的内容,因为这会覆盖 Anaconda 正常操作所需的文件。

    必须在安装红帽企业 Linux 之后才可安装这些光盘。

  • 红帽企业 Linux 4(以及所有更新)附带的 GRUB 不支持软件监控(RAID1)。因此,如果您在 RAID1 中安装红帽企业 Linux 4,则会在第一个硬盘而不是主引导记录(MBR)中安装引导装载程序,这会使得系统无法引导。

    如果您要在 RAID1 中安装红帽企业 Linux 4,您应该首先清除之前存在于 MBR 中的引导装载程序。

  • 当在使用平板监视器以及 ATI 显卡的系统中以文本模式安装红帽企业 Linux 4 时,屏幕可能会偏移。出现此情况时,屏幕的一部分会被屏蔽。

    如果出现这种情况,请使用参数 linux nofb 进行安装。

  • 当从红帽企业 Linux 4.6 升级到这个发行本时,minilogd 可能会记录一些 SELinux 否定。这些日志记录的出错信息是无害的,可忽略。

功能更新

使用 SHA-256/SHA-512 的密码散列法

现在支持使用 SHA-256 和 SHA-512 散列功能密码散列法。

要在安装的系统中从 SHA-256 切换到 SHA-512,请运行 authconfig --passalgo=sha256 --kickstart 或者 authconfig --passalgo=sha512 --kickstart。不会影响现有用户帐户除非改变其密码。

对于新安装的系统,只能为 kickstart 安装配置使用 SHA-256 或 SHA-512。要做到这一点,请使用 kickstart 命令 auth 的 --passalgo=sha256 或 --passalgo=sha512,另外,如果出现 --enablemd5 选项,请将其移除。

如果您不使用 kickstart 进行安装,请按如上所述使用 authconfig,然后更改安装后生成的所有密码(包括根密码)。

还要在 libuser、pam 和 shadow-utils 命令中添加适当的选项以支持这些密码散列法算法。authconfig 可以自动配置需要的选项,因此通常不需要手动修改:

  • 目前,在 /etc/libuser.conf 文件的 [defaults] 部分支持 crypt_style 选项的新数值以及 hash_rounds_min 和 hash_rounds_max 命令的新选项。有关详情请参考 /usr/share/doc/libuser-[libuser version]/README.sha。

  • 目前,新选项 sha256、sha512 和 rounds 由 pam_unix PAM 模块支持。有关详情请参考 /usr/share/doc/pam-[pam version]/txts/README.pam_unix。

  • 目前,以下 /etc/login.defs 的新选项由 shadow-utils 支持:

    • ENCRYPT_METHOD — 指定要使用的加密方法。有效值为 DES、MD5、SHA256、SHA512。如果定义了这个选项,则将忽略 MD5_CRYPT_ENAB。

    • SHA_CRYPT_MIN_ROUNDS 和 SHA_CRYPT_MAX_ROUNDS — 如果将 ENCRYPT_METHOD 设定为 SHA256 或者 SHA512,则使用此选项指定要使用的散列轮叫数目。如果这两个选项都没有数值,则由 glibc 选择默认值。如果只设置了一个选项,那么加密方法会指定轮叫数目。

      如果使用全部以上两个选项,它们会指定一个相容间隔,并从中随机选择一个轮叫数。选择的轮叫数应限制在相容间隔 [1000, 999999999] 内。

comps.xml 中的 OFED

组群 OpenFabrics Enterprise Distribution 目前包含在 comps.xml 中。这个组群包含用于高性能联网和群集(例如:InfiniBand 和远程直接内存访问)的组件。

虚拟化

这个更新使用了半虚拟块设备以及网络驱动程序,它可提高全虚拟客户端的性能。另外,您现在可以在每个域中使用三个以上的网络接口(VNIF)号码。

divider

divider=[value] 选项是一个内核命令行参数,它可允许您调整系统时钟速率,并将同一可见 HZ 计时数值用于用户空间应用程序。

使用 divider=[value] 选项可降低 CPU 消耗,同时在降低计时操作以及侧写的前提下提高效率。这在虚拟环境中也同样对某些应用程序有用。

标准 1000Hz 时钟的有用 [values] 为:

  • 2 = 500Hz

  • 4 = 250Hz

  • 10 = 100Hz(红帽企业 Linux 前一个版本使用的数值)

请注意:虚拟内核默认使用 250HZ 时钟。因此,在 dom0 或者虚拟客户端中它都不需要 divider=[value] 选项。

Firefox Rebase

现在 Firefox 已更新至版本 3.0。在这个更新中采用了一些修复和改进,最值得注意的是:

  • 当打开 Firefox 浏览器窗口时可正确载入设置主页。

  • 当您搜索字符串 "do" 时,Firefox 不会再崩溃。

  • 现在,64 位模式的 Firefox 可以正确载入 ext Java 脚本程序库。在 Firefox 之前的版本中,使用这个程序库的基于网页的应用程序要么需要很长时间载入,要么根本无法载入。

  • 在 Firefox 处理 jar:URI 方案的方法中发现一个跨网站脚本缺陷。这个缺陷可能让一个恶意网站可以对用户进行脚本攻击。在这个更新中修复了这个安全性问题。

  • 在 Firefox 处理异常内容的方法中发现一些缺陷。包含这种内容的网站可能导致 Firefox 崩溃或者根本无法执行任意编码,因为用户正在运行 Firefox。在这个更新中已经修复了这个安全性问题。

  • 在 Firefox 使用网页设置 window.location 属性的方法中发现一个竞态条件。这个缺陷可能导致网页设置一个任意 Referer 标头,这可能对只依赖 Referer 标头网站进行导致跨网站请求伪造(CSRF)攻击。在这个更新中修复了这个安全性问题。

  • 现在 Firefox 可在配备外置显示的笔记本电脑中正常工作。

请注意:这个 Firefox 不会对 JavaScript 或者目前使用的 Firefox 插件提供完全向下兼容。

另外,红帽已经注意到一些大量商业网站应用程序已经依赖现有的 Firefox 更新中提到的一些跨网站脚本缺陷。这些脚本缺陷见于以下链接:

接下来,使用这些商业网页应用程序可能会造成一些性能的损失。您可以注意到 Firefox 错误控制台(工具 = > 错误控制台)出现的 Java 脚本错误。红帽目前正在和相关销售商商讨此问题。

和内核相关的更新

一般内核更新
  • 现在,iostat 根据分区状态以及 I/O 性能输出统计数据。

  • 在这个发行本中,I/O 计数现在可以输出更详细的核心统计数据。这是通过应用上级已经使用的 ru_inblock 和 ru_outblock 达到的。

  • show_mem() 输出现在包括全部页缓存页面的数。这使得发送到控制台以及 /var/log/messages 中的调试信息更加有用,特别是在缺少内存而终止进程的时候。

  • 现在删除了 O_ATOMICLOOKUP 标签。所有当前用户空间守护进程都不使用这个标签。另外,通常 O_ATOMICLOOKUP 使用的位由另一个标签(O_CLOEXEC)使用。因此删除了 O_ATOMICLOOKUP 以避免由于位共享造成的冲突。

  • 内核现在将进程限制信息导出到 /proc/[PID]/limits(其中 [PID] 是进程 ID)。

  • 现在可将参数 TCP_RTO_MIN 最大配置为 3000 毫秒。在之前的版本中 TCP_RTO_MIN 是一个不可调节的内核参数。

    这个更新提供了更多的 TCP/IP 灵活性,且启用了根据无线传输(例如:移动电话传输速率)重启传输的应用程序。

    您可以通过 ip route 配置 TCP_RTO_MIN 参数。例如:将 TCP_RTO_MIN 设置为最大的 3000 毫秒,请使用:

    ip route change [route] dev eth0 rto_min 3s

    有关 ip route 的详情请参考 man ip。

  • 目前采用了 udp_poll() 功能。这个更新减小了系统调用 select() 返回误报的可能性。

  • 您现在可以启用/禁用 32 位内节点数。要做到这一点,请使用内核参数 nfs.enable_ino64=。设定 nfs.enable_ino64=0 将会令 NFS 客户端为 readdir() 和 stat() 系统调用返回 32 位内节点数(而不是全部 64 位内节点数)。

    默认情况是将这个内核参数设置为返回真实的 64 位内节点数。

  • 您现在可以限制 NFS 写入低内存。要做到这一点,请将 /proc/sys/vm/nfs-writeback-lowmem-only 设为 1(默认情况是将其设为 0)。

    之前的版本并不包括这个功能,这使得 NFS 的读取性能在某些情况下会有所下降,特别是当系统遇到需要大量 NFS 读取/写入请求的时候。

  • 您现在可以设定在 dirty_ratio 和 dirty_background_ratio 计算中使用哪个映射文件页。要做到这一点,请将 /proc/sys/vm/write-mapped 设为 1(默认情况下是将其设为 0)。

    将 /proc/sys/vm/write-mapped 设为 1 可让您使用更迅速的 NFS 读取性能。请注意:这样做可能会让您有缺少内存的危险。

  • CIFS 现在更新到版本 1.50C。这个更新应用了一些改进和故障修复,其中包括挂载 OS/2 共享的功能。

  • 现在支持核转储伪装。这样可在生成核转储文件时,允许核转储进程跳过某个进程的共享内存片段。这个特性还允许您选择是否为每个进程转储匿名共享内存。

    当进程被转储时,会将所有匿名内存写入核文件,只要核文件的大小没有限制。在有些情况下,您可能想要防止转储一些内存片段(比如大的共享内存)。反之,您还可能想要将 file-backed 内存片段保存到一个独立的核文件中。

    出于这些目的,您可以使用 /proc/[pid]/coredump_filter 指定要转储 [pid] 进程的哪个内存片段。coredump_filter 是一个内存类型位掩码。如果设置了位掩码,则需转储响应内存类型的内存片段。

    支持以下内存类型:

    • bit 0 — 匿名专用内存

    • bit 1 — 匿名共享内存

    • bit 2 — file-backed 专用内存

    • bit 3 — file-backed 共享内存

    要为 [pid] 设置位掩码,请为相应的 /proc/[pid]/coredump_filter 设置位掩码。例如:要防止对所有附加到进程 1111 的共享内存片段进行转储,请使用:

    echo 0x1 > /proc/1111/coredump_filter

    coredump_filter 的默认值为 0x3,即指定转储所有匿名内存片段。另外请注意:不考虑位掩码的状态,从不转储 MMIO 页(比如桢缓冲),而永远要转储 vDSO 页。

    当生成一个新的进程时,该进程会从其父进程中继承位掩码状态。因此,红帽建议您在运行该程序前设定 coredump_filter。要做到这一点,请在运行此程序前将所需位掩码 echo 到 /proc/self/coredump_filter 文件中。

关于此平台的特定内核更新
  • Oprofile 目前支持 Greyhound 硬件中基于事件的侧写。

  • 现在支持 AMD ATI SB800 SATA 控制器。

  • 现在支持使用 40 针 IDE 电缆的 AMD ATI SB600 和 SB700 SATA 控制器。

  • 目前在 AMD ATI SB700 中支持 64 位直接内存访问(DMA)。

  • 已经添加了支持 Intel ICH10 所需的 PCI 设备 ID。

驱动更新

常规驱动程序/平台更新
  • 目前启用了 i2c-piix4 内核模块以便提供对 AMD SBX00 SMBus 的支持。

  • i5000_edac:添加的用来支持 Intel 5000 芯片集 的驱动程序。

  • i3000_edac:支持 Intel 3000 3010 芯片组的驱动程序。

  • 目前添加了 Intel Tolapai 芯片集缓冲信息修正。这确保正确列出了硬件。

  • wacom:更新的驱动程序以便添加对以下输入设备的支持:

    • Intuos3 12x19

    • Intuos3 12x12

    • Intuos3 4x6

    • Cintiq 20wsx

  • i2c-i801:更新的驱动程序(附带对应的 PCI ID),以支持 Intel Tolapai。

  • sata_svw:更新的驱动程序,以支持 Broadcom HT1100 芯片组。

  • libata:更新的驱动程序,以便通过删除黑名单中的 Hitachi 驱动器启用原生命令队列(Native Command Queuing,NCQ)。

  • ide:更新的驱动程序以便包括 ide=disable,一个可用来禁用 ide 驱动程序的内核 PCI 模块参数。

  • psmouse:更新的驱动程序以便正确支持使用 cortps 协议的输入设备。这种输入设备包括四键鼠标以及 Cortron 开发的滚轮设备。

  • eHEA:更新的驱动程序以便与上级版本对应。这个更新采用了以下上级故障修复以及改进,加强了对 IBM i6 和 p6 的支持,其中包括:

    • 支持 Large Recieve Offload(LRO)作为联网模块。

    • 添加了支持 netdump 和 netconsole 模块所需的 poll_controller。

  • zfcp:更新的驱动程序以便应用上级故障修复。这个更新使用了一些故障修复,其中最值得注意的是:

    • 当热插拔光纤后重新在多路径环境中打开适配器时,受到影响的路径不会再被标记为 failed。使用这个更新,会在类似的事件中正确清理相关适配器标签。

    • 当 fsf 请求超时时,修复后不再将该适配器标记为 failed。当成功启用适配器时可清理 ZFCP_STATUS_COMMON_ERP_FAILED 标签。

    • 目前在重新成功启用适配器时会清理 BOXED 标签。

    • 目前修复了可能导致 SCSI 栈以及 ERP 线程(在有些情况下,当注册了某些设备时)停滞的故障。

    • 当使用 chccwdev 将一个设备在多路径环境中标记为 "offline" 时,I/O 不再停滞在所有路径中。另外,当使用 chccwdev 使同一设备成为在线状态时,它仍将使用正确的路径检查程序。

网络
  • bnx2x:添加的驱动程序以便在 Broadcom 5710 芯片组中支持网络适配器。

  • cxgb3:更新的驱动程序以便支持 Chelsio 10G 以太网控制器以及 OFED。

  • realtek:更新的驱动程序以便支持 Realtek RTL8111 和 RTL8168 PCI-E 网卡。

  • e1000:更新的驱动程序以便支持可替换 MAC 地址,要支持虚拟连接构架则需要此驱动程序。

  • e1000e:更新至最新上级版本的驱动程序。这个更新提供了对 ICH9m 和 82574L Shelter Island 网卡的支持,并应用了一些上级修复。

  • bnx2:更新至版本 1.6.9 的驱动程序。这个更新应用了一些上级更改,并提供对 Broadcom 5709s 芯片集的支持。

  • igb:更新至上级版本 1.0.8-k2 的驱动程序。这个驱动程序版本目前支持 Intel 82575EB (Zoar) 芯片集。

  • s2io:更新至版本 2.0.25.1 的驱动程序,可支持 Neterion Xframe-II 10GbE 网络适配器。

  • tg3:更新至上级版本 3.86 的驱动程序。这个更新采用了一些修复和改进,其中包括:

    • 修复了 irq_sync 竞态条件问题。

    • 启用了 Auto-MDI。

  • forcedeth:更新到上级版本 0.61 的驱动程序。这个更新提供对以下芯片集的支持:

    • MCP73

    • MCP77

    • MCP79

    这个更新还提供一些与 WOL、MAC 地址序列以及 tx 超时等问题相关的故障。

存储
  • stex:更新至版本 3.6.0101.2 的驱动程序。这个更新应用了一些上级改进和故障修复。

  • mpt fusion:更新至版本 3.12.19.00 的驱动程序组。这个更新应用了一些改进和修复,其中最值得注意的是:

    • 目前在 mptsas.c、mptspi.c 和 mptfc.c 中添加了修改队列深度的调节参数。这些参数为 mptsas_device_queue_depth、mptspi_device_queue_depth 和 mptfc_device_queue_depth。这些参数的默认值为 48。

    • 目前支持的最大内存为 36GB,scatter/gather 条目最大值为 1078。

    • 添加标签 ioc->broadcast_aen_busy。这个标签是在运行 mptsas_broadcast_primative_work 线程时设置的。当公布附加 aen 事件时,应将其忽略,因为已经设定了 ioc->broadcast_aen_busy 标签。

      另外,会停止 SCSI_IO 命令并在之后设定 ioc->broadcast_aen_busy 标签时重新排队。当 mptsas_broadcast_primative_work 线程完毕后会清理这个标签。

    • 现在,如果在执行了 sync cache 命令,而未在载入驱动程序时,内部命令超时程序会执行诊断重置以便清理停滞状态。这个功能是通过添加两个超时程序实现的:一个超时程序处理所有与域确认不相关的内部命令,另一个处理与域确认相关的命令。

    • 域确认超时程序现在执行总线重置,而不是目标重置。

    • 现在当完成一个 Task Management 请求(通过 IOCTL 界面)时,会删除相关的 IOCTL 计时器。这样可防止计时器过期。计时器过期可导致出现主机重置,即使在 Task Management 请求已经成功完成的情况下也会如此。

  • qla2xxx:更新至版本 8.02.00-k5 的驱动程序。这个 qla2xxx 更新添加了以下支持:

    • EHAFT 是 QLogic 主机总线适配器装置,可提供有关光纤设备的性能信息。

    • 8GB 光纤设备。

    这个更新还应用了一些来自上级的改进,其中一个修复的 bug 可防止驱动程序在回路中等待,因为已经将其标记为 LOOP_DEAD 状态。

  • qla3xxx:更新到版本 v2.03.00-k4-rhel4.7-01 的驱动程序。这个更新修复了一个 bug,即如果在 VLAN 中使用属于 qla3xxx 驱动程序的接口,则将无法处理 inbound completion,并将其转给 TCP/IP 栈。

  • qla4xxx:更新到 5.01.01-d1 版本的应用程序,应用了以下修复:

    • 现在会为同一目标的每个可用端口生成一个会话。另外,修复了令 qla4xxx 无法为一些目标(如在故障切换或者不小心拔掉电缆之后)执行重新登录请求的故障。

    • 在 qla4xxx 之前的版本中,I/O 队列深度不受 "queue full" 错误的影响。现在,当发生 "queue full" 时,将会恰当调节队列深度,这样提高了对 I/O 错误的处理能力,继而还将会在每个目标中为 LUN 限制队列深度。

    • 目前会在初始化固件前启用 SCSI 功能。修复这个故障可保证 SCSI 功能可接收到所有软重置通知或者在初始化固件完成之前发生的严重错误。

    • 现在修复了阻止操作系统扫描一些状态从 "non-active" 变为 "active"(在驱动程序初始化的过程中)目标的故障。

  • CCISS:更新到版本 3.6.20-RH1 的驱动程序。这个更新为以后的 SAS/SATA 控制器提供支持,并应用了以下更改:

    • 添加了 I/O 控制 sg_io。这个 ioctl 可用来提高对多路径的支持。

    • 修改了 /proc/driver/cciss 条目以防止在系统中安装大量驱动程序时系统崩溃。

    • 现在删除了在 cciss 驱动程序中的 READ_AHEAD 设置。cciss 驱动程序现在将使用块层,默认为 256。测试显示设置 READ_AHEAD=1024 无法获得一贯的性能改进,在有些情况下,这个设置还可能会造成系统挂起。

  • megaraid_sas:更新到版本 3.18 的驱动程序,可支持在 MegaRAID 模式中运行的 LSI 1078 芯片集。另外,这个更新还应用了一些故障修复,其中包括:

    • 现在 MFI_POLL_TIMEOUT_SECS 是 60 妙(原来是 10 秒)。这是为了适应固件要求,可将固件对 INIT 命令的最长响应时间提高到 60 秒。

    • 现在修复了导致芯片持续重置以及由于桢计数引起的命令超时故障。使用这个更新,驱动程序将根据需要向固件发送正确的桢计数。

    • 添加模块参数 poll_mode_io 以支持查询。

  • arcmsr:更新到版本 1.20.00.15.rh 的驱动程序。这个更新采用了一些故障修复以及改进,另外,它还提供对以下 SATA RAID 适配器的支持:

    • ARC1200

    • ARC1201

    • ARC1202

技术预览

红帽企业 Linux 4.7 的订阅服务现在还不支持 Technology Preview 特征,它的功能还不完备,不适合于作为产品使用。然而,这些特征可以方便客户,提供了更丰富的功能。

客户可能发现这些特征在非产品环境中很有用。在某个技术预览被完全支持之前,客户也可以随时提供反馈和功能方面的建议。对于严重的安全性问题,我们将提供勘误表。

在某个技术预览特征的开发过程中,其他的组件可能会提供给公众进行测试。Red Hat将在以后的版本里完全支持技术预览。

Systemtap

Systemtap 提供免费的软件(GPL)基础架构来简化 Linux 系统的信息的收集。它可以协助性能或功能问题的诊断。依靠 systemtap,开发者不再需要遵循枯燥的编码、重编译、安装和重启来收集数据。

gcc

GNU Compiler Collection (gcc-4.1) 仍作为技术预览包含在这个发行版本里。这个编译器最开始是在红帽企业 Linux 4.4 里作为技术预览引入的。

关于 gcc-4.1 的更多信息,请参考其项目网站 http://gcc.gnu.org/。 gcc-4.1.2 的参考手册也可以在 http://gcc.gnu.org/onlinedocs/gcc-4.1.2/gcc/ 上找到。

OpenOffice 2.0

OpenOffice 2.0 现在作为技术预览包含在这个发行版本里。这个套件进行了一些改进,如 ODF 和 PDF 方面的功能、对数字签名的支持以及在格式和界面上对开源套件的兼容性。此外,OpenOffice 2.0 Spreadsheet 添加了对 Pivot table 的支持,且现在可以处理多达 65,000 行的数据。

关于 OpenOffice 2.0 的更多信息,请参考 http://www.openoffice.org/dev_docs/features/2.0/index.html。

autofs5

autofs5 作为技术预览包含在这个发行版本里。新版本的 autofs 解决了几个在多操作系统环境里长期存在的互用性问题。autofs5 也增强了下面的功能:

  • 直接映射支持,提供一种在文件系统层次结构的任何位置自动挂载文件系统的机制。

  • 对懒(Lazy)挂载和卸载的支持

  • 通过新的配置文件 /etc/autofs_ldap_auth.conf 增强了对 LDAP 的支持

  • 对使用 nsswitch.conf 的完全的实施

  • 用于直接映射的多重主映射条目

  • 它是映射包含的完整实现,它允许 autofs 主映射包含指定映射的内容。

目前,autofs5 主映射词汇分析器(lexical analyzer)不能够正确地解析挂载点或映射规格里的使用引号的字符串。因此,使用引号的字符串应该直接写在映射文件里。

这个更新版本里仍然将缺省安装和运行 autofs。因此,如果要使用功能更强的 autofs5,您需要手工安装 autofs5 软件包。

您也可以将 autofs 和 autofs5 都安装。然而,您应该只使用其中一个来提供自动挂载服务。要安装 autofs5 并使其作为自动挂载器,您需要执行这些步骤:

  1. 以根用户登录并用 service autofs stop 终止 autofs 服务。

  2. 用 chkconfig autofs off 命令禁用 autofs 服务。

  3. 安装 autofs5 软件包。

  4. 用 chkconfig autofs5 on 命令启用 autofs5 服务。

  5. 用 service autofs5 start 命令启动 autofs5。

关于 autofs5 的更多信息,请参考下面的 man 页面(在安装了autofs5 软件包后)。

  • autofs5(5)

  • autofs5(8)

  • auto.master.v5(5)

  • automount5(8)

您也可以参考 /usr/share/doc/autofs5-<version>/README.v5.release 来获得更多信息。

已解决的问题

  • 当类似 systool 的应用程序读取 /sys/class/scsi_host/host<scsi host number>/mbox(由 Emulex lpfc 驱动程序生成)时,不会在控制台出现无关痛痒的 "Bad State" 信息,也不会将其记录到系统日志文件中。

  • 目前,在引导过程中内核在打印到串口前会发送 Data Terminal Ready (DTR)信号。有些设备会需要 DTR 确定。会将内核引导信息打印到这种设备的串口控制台中。

  • 在红帽企业 Linux 4.6 中,不会在通过串口控制台安装操作系统时出现登录提示,在本发行本中修复了这个故障。

已知问题

  • openmpi 和 lam 之前版本中的 bug 可能会令您无法升级这些软件包。同样的 bug 还可能导致 up2date 无法升级所有软件包。

    这个 bug 会导致在试图升级 openmpi 或者 lam 时出现以下错误:

    error: %preun(openmpi-[version]) scriptlet failed, exit status 2
    

    这个 bug 还会导致在试图通过 up2date 升级所有软件包时出现以下错误(登录到 /var/log/up2date):

    up2date Failed running rpm transaction - %pre %pro failure ?.
    

    因此,您首先需要手动删除 openmpi 和 lam 的旧版本以便避免出现这些错误信息。要做到这一点,请使用以下 rpm 命令:

    rpm -qa | grep '^openmpi-\|^lam-' | xargs rpm -e --noscripts --allmatches

  • 当从一个配置的存储系统中删除 LUN 时,不会在主机中有所显示。在这种情况下,使用 dm-multipath 将导致 lvm 命令挂起,因为 LUN 已经变为 stale 状态。

    要解决这个问题,请删除所有设备并将 /etc/lvm/.cache 文件中的 mpath 链接指定到 stale LUN。要找到这些条目,请运行以下命令:

    ls -l /dev/mpath | grep <stale LUN>

    例如:如果 <stale LUN> 是 3600d0230003414f30000203a7bc41a00,则会出现以下结果:

    lrwxrwxrwx 1 root root 7 Aug  2 10:33 /3600d0230003414f30000203a7bc41a00 -> ../dm-4
    lrwxrwx--rwx 1 root root 7 Aug  2 10:33 /3600d0230003414f30000203a7bc41a00p1 -> ../dm-5
            

    意思是说 3600d0230003414f30000203a7bc41a00 与两个链接匹配:dm-4 和 dm-5。

    因此,应从 /etc/lvm/.cache 中删除以下行:

    /dev/dm-4 
    /dev/dm-5 
    /dev/mapper/3600d0230003414f30000203a7bc41a00
    /dev/mapper/3600d0230003414f30000203a7bc41a00p1
    /dev/mpath/3600d0230003414f30000203a7bc41a00
    /dev/mpath/3600d0230003414f30000203a7bc41a00p1
    
  • 在 HA-RAID 双系统配置中,会将两个 SAS 适配器插入到双系统中并连接到共享的磁盘柜中。在两个 SAS 适配器中将 Preferred Dual Adapter State 属性设置为 Primary 可激发竞态条件,并导致在两个 SAS 适配器之间进行无限次故障切换。这是因为只能将一个 SAS 适配器设置为 Primary。

    要防止这个错误发生,如果应该将一个 SAS 适配器设为 Primary,请确定将另一个 SAS 适配器的 Preferred Dual Adapter State 设为 None。

  • 如果您需要使用 hp_sw 内核模块,请安装更新的 device-mapper-multipath 软件包。

    您还会需要正确配置 HP 阵列以便正确使用主动/被动模式,并识别来自 Linux 机器的连接。要做到这一点,请执行以下步骤:

    1. 使用 show connections 可确定每个连接的全球端口名称(WWPN)。下面是带两个连接的 HP MSA1000 阵列的 show connections 输出示例:

      Connection Name: <Unknown>
         Host WWNN = 200100E0-8B3C0A65
         Host WWPN = 210100E0-8B3C0A65
         Profile Name = Default
         Unit Offset = 0
         Controller 2 Port 1 Status = Online
      
      Connection Name: <Unknown>
         Host WWNN = 200000E0-8B1C0A65
         Host WWPN = 210000E0-8B1C0A65
         Profile Name = Default
         Unit Offset = 0
         Controller 1 Port 1 Status = Online
      
    2. 运行以下命令正确配置每个连接:

      add connection [connection name] WWPN=[WWPN ID] profile=Linux OFFSET=[unit offset]

      请注意:[connection name] 可任意设定。

      使用给出的示例,正确的命令应该是:

      add connection foo-p2 WWPN=210000E0-8B1C0A65 profile=Linux OFFSET=0

      add connection foo-p1 WWPN=210100E0-8B3C0A65 profile=Linux OFFSET=0

    3. 再次运行 show connections 以确定正确配置了每个连接。对于每个给出的示例,正确的配置应该为:

      Connection Name: foo-p2
         Host WWNN = 200000E0-8B1C0A65
         Host WWPN = 210000E0-8B1C0A65
         Profile Name = Linux
         Unit Offset = 0
         Controller 1 Port 1 Status = Online
      
      Connection Name: foo-p1
         Host WWNN = 200100E0-8B3C0A65
         Host WWPN = 210100E0-8B3C0A65
         Profile Name = Linux
         Unit Offset = 0
         Controller 2 Port 1 Status = Online
      
  • 红帽不鼓励在 EXT3 文件系统中使用 quota,这是因为在有些情况下,这样做可导致停滞。

    测试显示 kjournald 有时可以阻滞一些在运行 quota 时的 EXT3 特殊调出。因此,红帽不计划在红帽企业 Linux 4 中修复这个问题,因为这个修改可能会造成很大的影响。

    请注意:这个问题不会出现在红帽企业 Linux 5 中。

  • 对 Mellanox MT25204 的硬件测试显示,在某些高负载情况下会出现内部错误。当 ib_mthca 驱动程序报告这个硬件的灾难性错误时,它通常与完成队列深度不足有关,这与由用户应用程序产生的大量工作请求有关。

    尽管驱动程序将重置硬件并从该事件中恢复,但会丢失所有出现错误时的存在连接。这通常会导致用户应用程序的片段错误。另外,如果在发生错误时正在运行 opensm,那么您需要手动重启该命令以便恢复正确的操作。

  • 当您双击桌面共享连接图标时,它会显示其上下文菜单。如果您使用右键单击此图标则不会显示。而其它所有图标都会在您使用右键单击时显示其上下文菜单。

( x86 )